About

I'm Mike Pope. I live in the Seattle area. I've been a technical writer and editor for over 30 years. I'm interested in software, language, music, movies, books, motorcycles, travel, and ... well, lots of stuff.

Read more ...

Blog Search


(Supports AND)

Google Ads

Feed

Subscribe to the RSS feed for this blog.

See this post for info on full versus truncated feeds.

Quote

The way I figure it, the only reason to grow up is so you can afford to buy yourself all the crap your parents wouldn't buy you when you were a kid.

Jeff Atwood



Navigation





<September 2017>
SMTWTFS
272829303112
3456789
10111213141516
17181920212223
24252627282930
1234567

Categories

  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  
  RSS  

Contact

Email me

Blog Statistics

Dates
First entry - 6/27/2003
Most recent entry - 9/23/2017

Totals
Posts - 2453
Comments - 2558
Hits - 1,984,654

Averages
Entries/day - 0.47
Comments/entry - 1.04
Hits/day - 382

Updated every 30 minutes. Last: 11:04 PM Pacific


  08:36 AM

The beta version of WebMatrix 2 was put out for public consumption around the time of the //build/ conference in September. Very nice.

However, installing WebMatrix 2 beta makes it harder to install (reinstall) the WebMatrix 1 (actually, 1.1), should you ever need to do that. (I did recently.) If you go to the download page and try to install the non-beta version of WebMatrix you won't get it, even if you carefully and explicitly don't choose the beta download option. You'll be offered WebMatrix 2 beta only.



Turns out this is due to the installer. WebMatrix is installed via Web Platform Installer (WebPI). When you install the Beta release, you first get an updated version of WebPI, and the updated version of WebPI knows only about the beta version of WebMatrix 2.

Anyway, long story short, if you've instaslled WebMatrix 2 Beta but for some reason need to reinstalled WebMatrix 1, you need to uninstall WebPI.

(Thanks to Chris Sfanos and his WebMatrix expertise for sorting this one out for me.)

[categories]   ,

|